漏洞描述

Apache Kylin™是一个开源的、分布式的分析型数据仓库。近日Apache Kylin官方修复 CVE-2020-13937 API未授权访问漏洞。攻击者可构造恶意请求,访问API地址,可以获取Apache Kylin的相关配置信息,从而导致身份凭证等信息泄漏。阿里云应急响应中心提醒 Apache Kylin 用户尽快采取安全措施阻止漏洞攻击。
 
 

影响版本

Kylin 2.x.x
Kylin <= 3.1.0
Kylin 4.0.0-alpha
 
 

FOFA

title="Kylin"


 

漏洞复现

访问http://127.0.0.1:7070/kylin/api/admin/config即可看到配置信息


 
 

修复建议

升级到安全版本,或执行以下缓解措施:

编辑 "$KYLIN_HOME/WEB-INF/classes/kylinSecurity.xml";

删除下列行 "<scr:intercept-url pattern="/api/admin/config" access="permitAll"/>";



重启 Kylin实例以使其生效。