漏洞复现-Linux实验室

Logo

  • 发布于:2022-06-11

    1

    WordPress插件Stafflist...
    漏洞描述 已在中发现跨站点脚本反映的漏洞WordPress插件stafflist版本低于3.1.2。这允许未经身份验证的用户在其中运行任意javascript代码WordPress使用Stafflist插件。     影响插件 stafflist<3.1.2     漏洞复现 http://localhost:10003/wp-admin/admi...
    阅读 17 评论 0
  • 发布于:2022-06-11

    1

    WordPress Photo Gall...
    漏洞描述 插件没有正确地转义附加到SQL查询的$_POST['filteru tag']参数,这使得SQL注入攻击成为可能。     影响插件 photo-gallery <1.6.3     漏洞点分析 WordPress 安装过程可以参考之前公众号的文章。下载 Photo Gallery 插件 v1.6.2 版本并完成安装: ...
    阅读 38 评论 0
  • 发布于:2022-06-11

    1

    Microsoft Office MSD...
    漏洞描述 Windows MSDT 组件存在远程执行代码的信息,漏洞编号:CVE-2022-30190,漏洞威胁等级:高危。 该漏洞是由于 MSDT 被用户应用使用 URL 协议调用,攻击者通过社会工程诱使受害者从网站下载并打开特制文件,最终获取用户权限。     组件介绍 MSDT 是微软支持诊断工具 (Microsoft Windows Support Diagnosit...
    阅读 36 评论 0
  • 发布于:2022-06-11

    1

    Windows 打印后台处理程序特权提升...
    漏洞描述 Microsoft 最初在没有向我提供任何信息或确认的情况下修补了此漏洞,因此,在补丁发布时,我认为该漏洞被标识为 CVE-2022-22718,因为它是该版本中唯一未经任何确认的打印后台处理程序漏洞。我联系了 Microsoft 进行澄清,在补丁发布后的第二天,Institut For Cyber Risk 和我因 CVE-2022–21999 而获得认可。 在这篇博客文...
    阅读 30 评论 0
  • 发布于:2022-06-11

    1

    PHP远程命令执行漏洞复现 CVE-20...
    漏洞信息 mysqlnd/pdo 存在缓冲区溢出,可利用此漏洞导致远程代码执行.     影响范围 PHP 7.4 < 7.4.30 PHP 8.0 < 8.0.20 PHP 8.1 < 8.1.7     漏洞复现 测试 PHP 版本为:v8.1.6 ,启动 MySQL 服务: 配置 `php.ini` 启用 `pdo_mysql`...
    阅读 49 评论 0
  • 发布于:2022-06-09

    1

    Atlassian Confluence...
    漏洞描述 CVE-2022-26314 是一个未经身份验证的远程 OGNL 注入漏洞,导致在 Confluence 服务器(通常是 Linux 安装上的用户)的上下文中执行代码。鉴于该漏洞的性质,面向互联网的Confluence服务器面临非常高的风险。confluence 去年,Atlassian Confluence遭受了不同的未经身份验证和远程OGNL注入,CVE-2021-26084。维护...
    阅读 28 评论 0
  • 发布于:2022-06-09

    1

    linux内核提权漏洞复现CVE-202...
    漏洞信息 该漏洞的存在是由于Linux内核中某些*_OR_NULL指针类型的指针算法的可用性。本地用户可以运行特制的程序,最终以root权限执行任意代码,利用条件为低权限用户认证。     影响范围 linux内核 5.8 - 5.16     漏洞复现 内核版本 1.github下载利用exp git clone https://github.c...
    阅读 115 评论 0
  • 发布于:2022-06-08

    1

    WordPress User Meta ...
    描述 该插件不验证其um_show_uploaded_file AJAX操作的filepath参数,这可能允许低权限用户(如subscriber)通过路径遍历有效负载枚举web服务器上的本地文件 WordPress的一个易于使用的用户配置文件和管理插件,允许用户登录、重置密码、配置文件更新和使用extra进行用户注册字段,所有字段都位于前端,还有更多字段。用户Meta Pro是一个多功能用户Wo...
    阅读 41 评论 0
  • 发布于:2022-06-03

    1

    WordPress插件HubSpot <...
    描述 该插件不会验证提供给代理REST端点的代理URL,这可能允许具有edit_posts功能的用户(默认为contributor或更高版本)执行SSRF攻击CVE-2022-1239     影响插件 leadin <8.8.15     漏洞证明 作为具有edit_posts功能的经过身份验证的用户,请通过以下方式获取REST nonce ...
    阅读 39 评论 0
  • 发布于:2022-06-03

    1

    WordPress插件Contact F...
    描述 流行的WordPress插件Contact Form 7被发现容易受到无限制文件上传的攻击。CVE-2020-35489     插件影响 contact-form-7 <5.3.2     漏洞复现 将unicode特殊字符(从U+0000[null]到U+001F[us])附加到文件名,并通过ContactForm7上载功能上载 我们访问这...
    阅读 39 评论 0
  • 发布于:2022-06-02

    1

    WordPress Yoast SEO ...
    描述 供应商的描述,参考如下: “Yoast SEO 11.6 还修复了与 WordPress 中的术语页面有关的安全问题。在某些字段中允许使用未经过滤的代码。但是,这不会对单用户站点造成问题。在特定情况下,在多站点安装中,这可能会成为问题因为用户角色的运作方式。”     影响插件 wordpress-seo wordpress-seo-premiu...
    阅读 32 评论 0
  • 发布于:2022-06-02

    1

    Spring Security Rege...
    漏洞介绍 Spring Security 是 Spring 家族中的一个安全管理框架。在 Spring Security 正则表达式中使用带有 . 的 RegexRequestMatcher 的应用程序可能容易受到授权绕过。   影响版本 5.5.7 之前的 5.5.x5.6.4 之前的 5.6.x早期不支持的版本     漏洞复现 我们新建一个spring b...
    阅读 65 评论 0
  • 发布于:2022-06-02

    1

    DOM in hakimel/revea...
    描述 /plugin/notes/speaker-view.html 中的 onmessage 事件侦听器在将内容添加到网页之前不会检查 postMessage 的来源。易受攻击的代码允许任何来源在浏览器窗口上发布Message,并将攻击者的输入提供给攻击者可以在受害者的浏览器窗口托管显示时执行任意javascript代码reveal.js     影响版本 reveal.js...
    阅读 32 评论 0
  • 发布于:2022-06-02

    1

    WordPress The School...
    漏洞描述 该插件包含一个在其许可证检查代码中注入的混淆后门,该代码注册了一个 REST API 处理程序,允许未经身份验证的攻击者在该站点上执行任意 PHP 代码。     影响版本 WordPress The School Management < 9.9.7 school-management-pro     漏洞复现 curl -s -d &...
    阅读 35 评论 0
  • 发布于:2022-06-01

    1

    WordPress 5.8.3 对象注入...
    在撰写本文时,WordPress 为 Internet 上 43% 的网站提供支持。它的简单性和稳健性使数百万用户能够托管他们的博客、电子商务网站、论坛或静态网站。为了保护其用户,过去在代码库中引入了几种安全强化机制。 我们在 WordPress 核心中发现了一个有趣的对象注入漏洞 (CVE-2022-21663),该漏洞最近在5.8.3版本中得到了修复。对象注入是一个代码漏洞,它使攻击者能够...
    阅读 41 评论 0
  • 发布于:2022-06-01

    1

    WordPress 5.9 跨站点XSS...
    漏洞描述 WordPress(WP,WordPress.org)是一个免费的开源内容管理系统(CMS)用PHP[4]编写,并与MySQL或MariaDB数据库。功能包括插件架构和模板系统,在WordPress中称为主题 当具有作者或参与者角色的用户每当用户希望在帖子或页面中使用添加块功能,即XSS将执行。此外,post和page编辑器还允许执行xss负载直接复制和粘贴恶意javascript即可...
    阅读 46 评论 0
  • 发布于:2022-06-01

    1

    Wordpress 绕过 CORS 错误...
    说明 默认情况下,Wordpress 允许公共访问 Rest API 以获取有关在系统上注册的所有用户的信息。     受影响的平台:[网站] *。https://████/wp-json/     重现步骤 1) Repreat URL易受Burp Suite攻击 2) 如果将Origin-parameter参数添加到请求标头,响应标头将拒绝 3) 绕过...
    阅读 30 评论 0
  • 发布于:2022-06-01

    1

    WordPress 4.7.2 unzi...
    概括 Wordpress 的 unzip_file 函数 ( https://codex.wordpress.org/Function_Reference/unzip_file ) 在提取 zip 文件时容易受到路径遍历的影响。使用此函数提取不受信任的 zip 文件,这可能会导致通过将任意 PHP 文件放置在 Web 服务器的 DocumentRoot 中来执行代码。     ...
    阅读 33 评论 0
  • 发布于:2022-06-01

    1

    Wordpress 5.8.2 商店 ...
    描述 商店 XSS 错误在于文字发布添加“slug”功能。脚本在插入成功后可在管理员的界面两侧执行。用户只需拥有“代理”权限,即可执行此错误,因为只需在文章编辑功能中执行。     影响版本 Wordpress <= 5.8.2     漏洞分析 1. 单词压缩 slug Word 新闻发布是 Word ...
    阅读 46 评论 0
  • 发布于:2022-05-29

    1

    Ruby​​ 3.1.1 Regexp...
    漏洞描述 在 Ruby 3.x 之前的 3.0.4 和 3.1.x 之前的 3.1.x 的 Regexp 编译器中发现了双重自由。如果受害者试图从不受信任的用户输入创建正则表达式,则攻击者可能能够写入意外的内存位置。     受影响的版本 ruby​​ 3.0.3 或之前的版本 ruby​​ 3.1.1 或之前的版本 ruby 2.6 系列和 2.7 系列不受影响 &nbs...
    阅读 38 评论 0